Laptop schaltet Grafikkarte nicht um

  • Min,


    vielleicht hat ja einer hier im Forum eine Idee:


    Ich habe aktuel ein kleines Problem mit meinem Laptop:
    Er schaltet von der Intel Grafik nicht auf den Hochleistungs GPU um. (Nvidia)


    Das Gerät ist ein Lenovo Y570 (schon bissel älter) die externe Grafikkarte ist eine GT555m.


    Hab das ding schon mehrfach Platt gemacht und neu installiert (Win 7, WIn 8.1). Und auch verschiedenste Treiber probiert (inklusive der offiziellen).
    Aber er schalter nicht von der Intel CPU GPU auf die Nvidia GPU um.


    Jemand ne idee?

    Cuiusvis hominis est errare, nullius nisi insipientis perseverare in errore.

    Einmal editiert, zuletzt von Yoshi ()

  • Kann man leider nicht - man kann dort nur die Karten aktivieren oder deaktivieren (schalte ich die Intel GPU ab, hab ich kein Bild mehr)
    Der Switch zwischen den GPUs wird vom Intel Treiber verwaltet (wer auch immer auf so eine Idee kam.....)

    Cuiusvis hominis est errare, nullius nisi insipientis perseverare in errore.

  • Hallo Yoshi


    Bei deinen Problem gibt es einige Möglichkeiten.


    Um es einzugrenzen Mal ein paar Fragen.


    du schreibst...


    Zitat von Yoshi

    Ich habe aktuel ein kleines Problem mit meinem Laptop:
    Er schaltet von der Intel Grafik auf die externe Grafikkarte um.


    Das Gerät ist ein Lenovo Y570 (schon bissel älter) die externe Grafikkarte ist eine GT555m.


    Hab das ding schon mehrfach Platt gemacht und neu installiert (Win 7, WIn 8.1). Und auch verschiedenste Treiber probiert (inklusive der offiziellen).
    Aber er schalter nicht von der Intel CPU GPU auf die Nvidia GPU um.

    Erstens sind die beiden Aussagen irgendwie ein Widerspruch?! Oder hast du noch eine extra USB Graka am Laptop, sowas gibts ja auch. Schreib mal was dazu.


    Woher willst du wissen das er nicht umschaltet. Mit den Ausgängen am Laptop hat das nichts zu tun. Die werden alle entweder von der Embedded oder der externen Graka bedient. Bei Intel ist das ein fließender Process und nennt sich Lucid Technology s. Link und ist auf bestimmten Intel CPUs implementiert. Guck mal im BIOS, ob du eine Option "Render Standy oder so ähnlich findest.


    http://www.anandtech.com/show/…on-sandy-bridge-platforms



    Wie ist der Monitor angeschlossen? VGA, DVI, Displayport oder HDMI


    Möchtest du vielleicht einfach nur den Monitorausgang wechseln und bringst da etwas durcheinander?


    Was passiert, wenn du das OS mal komplett außen vor lässt, (am besten Platte oder HDD rausnehmen) und einfach mal den Funktionstastenaufruf zur Umschaltung des Monitorausgangs probierst? Tut sich da etwas?
    Einfach mal die Tastenkombi drücken und kurz warten. Gegebenenfalls mehrfach durchschalten. Gibt auch Anschlüsse die quasi intelligent sind, und aus irgendwelchen Gründen Probleme haben vorhandene Signalquellen zu erkennen.

  • Moin ntkernel32,


    Ja du hast recht die sind ein wiederspruch - ich habe da wohl ein Wort vergessen (sorry!) Ich habe das oben umgeschrieben dass es klarer ist was das Problem ist.
    Eine externe Graka via USB nicht in verwendung, ichmeinte tatsächlich die zusätzlich verbaute interne Graka von Nvidia.


    Z deiner Frage woher ich weiß dass er nicht umschaltet: Benchmark tests (und die daraus resultierenden Werte), Hohe CPU Auslastung die laut dem Prozess Explorer, die vom Intel HD Treiber verursacht wird, zu wenig Strom verbrauch im nicht idle und außerdem: fehlender DirectX11 Support.


    Die GT555m kann DirectX11 und das ist auch installiert - Plot Twist: Windows und co (+ Steam und Games) erkennen nur DirectX9 (Intel HD 3000). (Interessanter Nebenfakt: ArmA 3 läuft trotzdem :D , dafür alles andere nicht)


    Daher meine Feststeullung: Der Switch bei Last klappt nicht. Eigentlich kann auch im Nvidia Treiber direkt auswählen welche Anwendung direkt mit der GT555m gestartet werden kann (alles ausgegraut) oder aber man gehr per Rechtsklick au die Anwendung und wählt "mit Hochleistungs Grafikprozessor starten" (auch ausgegraut)


    Die Monitor ausgänge sind hier völlig irrelevant - Es wird der eigene Display vom Laptop verwendet, kein externer Bildschirm.


    Ich meinte die Option " Render Standby" bisher nicht im BIOS gefunden zu haben (ich kann Sie aber auch übersehen haben) - Ich werde das heute abend mal prüfen.
    Ebenfalls lese ich mir mal nachher deinen Link durch.


    Gruß

    Cuiusvis hominis est errare, nullius nisi insipientis perseverare in errore.

  • Gunman: ArmA 3 war jetzt nur ein Beispiel :D


    Steh aber auch Oben: Wenn ich versuche manuelle eine Anwendung im Treiber einem GPU zuzuweisen, ist die Option immer ausgegraut -> geht also nicht

    Cuiusvis hominis est errare, nullius nisi insipientis perseverare in errore.

  • Also, ich würde erstmal im Bios schauen, ob ich dort irgendwie die Intel GFX komplett deaktivieren kann. Läuft schließlich beides übers Motherboard, sprich also wenn dann im Motherboardbios. Gegebenenfalls auf Bios Updates prüfen.


    Dann würde ich mit DDU Nvidia Treiber komplett entfernen, alle Intel Treiber entfernen.


    Neustarten


    dann neueste intel inf installieren


    Neustarten


    Intel HD GFX Treiber installieren


    Neustarten


    neuesten Nvidia GFX Treiber installieren


    Wenns dann immer noch nicht läuft


    Treibereinstellungen von beiden Treiber prüfen


    Powermanagement Energieschema auf Höchstleistung stellen


    Intel HD Grafik einfach mal im Gerätemanager deaktivieren


    Wenn nicht eines davon hilft, kann ich leider nicht weiterhelfen


    mfg kernel

  • So ich hab gestern mal das BIOS geprüft.
    Die Intel karte lässt sich deaktivieren, aber ich dann beim Booten des OS kein Bild mehr. Ebenfalls habe ich nciht die Option "Render Standby gefunden" (oder etwas ähnliches)
    Bios Update habe ich noch nicht durchgeführt.


    Vor die Intel GPU gibt es wohl anscheinend für mein System keine neueren Treiber. Von Nvidia schln, aber da verhällt sich das Verhalten weiterhin gleich.


    Treibereinstellungen sind korrekt (da lässt sich nicht viel Einstellen)
    Das gesamte System steht auf Hochleistung (BIOS, Treiber)


    Deaktiviere ich die Intel HD via Geräte Manager -> Schwarzes bild

    Cuiusvis hominis est errare, nullius nisi insipientis perseverare in errore.