Ace 3, CBA und TFR schmieren ab

  • Lakeside

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Ace 3, CBA und TFR schmieren ab

    Hallo Leute,

    ich habe derzeit ein sehr komisches Problem auf meinen Arma 3 Server. Wenn auf den Server über 10 Spieler drauf sind. Stürzt nach einer weile einfach ACE, CBA und TFR ab. Dennach werden alle gekickt oder gebannt von Infinstar.
    Ich habe schon Infinstar raus genommen, dass hat aber nix gebracht.

    Hier meine Server Logs:
    arma3server_x64_2018-02-15_21-25-47.rpt


    Ich benutze die 3.12.0 von ACE 3 und die 3.6 von CBA

    Ich hoffe mir kann hier jemand weiterhelfen
  • AmaZiinG schrieb:

    Ich habe schon Infinstar raus genommen, dass hat aber nix gebracht.
    Ich hab nicht die geringste Ahnung, was "Infistar" ist, aber rausgenommen hast du es nicht:

    Quellcode

    1. servermod=(...);@infiSTAR_A3;(...)


    Quellcode

    1. 21:31:20 "<infiSTAR.de> infiSTAR dll loaded successfully"
    2. 21:31:20 "<infiSTAR.de> [GER] Syndicate-Life.de | No Whitelist | TS3: 89.163.255.134"
    3. 21:31:20 "<infiSTAR.de> icense accepted!"
    4. 21:31:20 "<infiSTAR.de> Loading infiSTAR code.."
    5. 21:31:20 "<infiSTAR.de> 0.4 - run.sqf - including AntiHack"
    6. 21:31:20 "<infiSTAR.de> VERSION: infiSTAR.de 02-12-2017 15-03-43 (v258)"
    7. 21:31:20 "<infiSTAR.de> 0.4 - STARTING"
    8. 21:31:20 "<infiSTAR.de> 0.4 - TESTING IF serverCommandPassword IS SET PROPERLY"
    9. 21:31:20 "<infiSTAR.de> 0.4 - serverCommandPassword IS FINE"

    usw usf...
  • Ich weiß garnicht wie Mods überhaupt abstürzen können.
    Infistar muss schonmal weg.

    Auch interessant finde ich wie du CBA, ACE, Syndicate Life und TFAR alle doppelt mitlädst. Das ist eine sehr interessante Verfahrensweise.
    Zusätzlich interessant sind diese Unmengen an Fehlern von halb kaputten Models in den Mods die du lädst.
    Oder

    Usage of deprecated Extended Event Handler "fired". Use "firedBIS" instead. Path: @Syndicate_Life\bin\config.bin\Extended_Fired_EventHandlers\CAManBase.
    Oder wie im log nichts von einem "Absturz" zu sehen ist.
  • commy2 schrieb:

    Also wenn "infinstar" schon mal ausgeschlossen werden kann, dann werden wohl entweder @Syndicate_Life oder die Skripte der Mission selbst das ganze kaputtmachen.
    Was bedeutet überhaupt "abstürzen"?
    Also wenn Attempt to override final function anfängt. Dann werden alle Leute gekickt oder gebannt von infinstar. Wenn ich infinstar ausmache dann funktioniert nix mehr. Man kann das ACE 3 Menü nicht mehr aufmachen und man kann auch nix mehr mit TFR machen.
    Es liegt an diesen Attempt to override final function, dass verursacht den Fehler aber ich weiß nicht welches Script oder Mod dies auslöst. Ich habe schon mein ganzen mod packet zerlegt. Und die Skripts die ich benutze sind alle frei verfügbar und auch viele andere Server benutzen diese und haben keine Probleme.
  • AmaZiinG schrieb:

    commy2 schrieb:

    Also wenn "infinstar" schon mal ausgeschlossen werden kann, dann werden wohl entweder @Syndicate_Life oder die Skripte der Mission selbst das ganze kaputtmachen.
    Was bedeutet überhaupt "abstürzen"?
    Also wenn Attempt to override final function anfängt. Dann werden alle Leute gekickt oder gebannt von infinstar. Wenn ich infinstar ausmache dann funktioniert nix mehr. Man kann das ACE 3 Menü nicht mehr aufmachen und man kann auch nix mehr mit TFR machen.Es liegt an diesen Attempt to override final function, dass verursacht den Fehler aber ich weiß nicht welches Script oder Mod dies auslöst. Ich habe schon mein ganzen mod packet zerlegt. Und die Skripts die ich benutze sind alle frei verfügbar und auch viele andere Server benutzen diese und haben keine Probleme.
    Ich kann mir gut vorstellen woran das "Attempt to override final function" liegt. Ich würde vorschlagen meine letzte Antwort nochmal zu lesen.
  • @dedmen meinst du das es eventuell an dieser Meldung liegen könnte:

    Quellcode

    1. Usage of deprecated Extended Event Handler "fired". Use "firedBIS" instead. Path: @Syndicate_Life\bin\config.bin\Extended_Fired_EventHandlers\CAManBase.

    oder wie ich meine Mods lade?

    Also meine Start Parameters habe ich jetzt mal verbessert:

    Quellcode: start.bat

    1. start arma3server_x64.exe -autoinit -servermod=@extDB3;@life_server;@CBA_A3;@ace;@Syndicate_Life;@ACEX;@task_force_radio "-config=server.cfg" "-bepath=C:\server\A3Master\battleye" -name=SyndicateLife "-profiles=config\SyndicateLife"
  • AmaZiinG schrieb:

    Infistar ist ein Admin Tool
    Eher ein schlechtes script-based Antihack Ding, basierend auf einem A2-DayZ Hack von Monkey, das weder sein Geld wert ist, noch effektiv, weil es haufenweise unschuldige Spieler bannt und perfekt für Exploits benutzt werden kann. Zero One kann da ein Liedchen von singen (sie benutzen es aber immer noch, manche sind echt nicht lernfähig).

    Quellcode

    1. 21:58:34 "<infiSTAR.de FNC_AH_KICKLOGSPAWN> ["""",[""James Ryon"",""76561198120601023"",""KICKME""],""2:1616""]"
    2. 21:58:34 "<infiSTAR.de FNC_AH_KICKLOGSPAWN> James Ryon(76561198120601023) Token - objByNetID civ_5"
    3. 21:58:34 "<infiSTAR.de FNC_AH_KICKLOGSPAWN> Bad PUID / Token: Token received [] belongs to [] and not [76561198120601023]"
    4. 21:58:34 "<infiSTAR.de>SURVEILLANCELOG| 0h 30min | James Ryon(76561198120601023) | Bad PUID / Token: Token received [] belongs to [] and not [76561198120601023] [02-12-2017 15-03-43 - v258]"
    5. 21:58:34 "<infiSTAR.de>KICKLOG| James Ryon(76561198120601023) isAdmin? true: SLOG_SKICK: Bad PUID / Token: Token received [] belongs to [] and not [76561198120601023] [02-12-2017 15-03-43 - v258]"
    6. 21:58:34 "<infiSTAR.de> CLIENT NO UID - SERVER RESOLVED: James Ryon(76561198120601023).. used allPlayers"
    7. 21:58:34 "<infiSTAR.de>SURVEILLANCELOG| 0h 30min | James Ryon(76561198120601023) | James Ryon(76561198120601023) isAdmin? true: SLOG_SKICK: Bad PUID / Token: Token received [] belongs to [] and not [76561198120601023] [02-12-2017 15-03-43 - v258]"
    8. 21:58:34 "<infiSTAR.de>KICKLOG| James Ryon(76561198120601023) isAdmin? true: SLOG_SKICK: James Ryon(76561198120601023) isAdmin? true: SLOG_SKICK: Bad PUID / Token: Token received [] belongs to [] and not [76561198120601023] [02-12-2017 15-03-43 - v258]"
    Man kann aufgrund des beknackten Logs nur erahnen, was da vor sich geht, das sieht aber so aus, als ob der Server überlastet ist.

    AmaZiinG schrieb:

    meinst du das es eventuell an dieser Meldung liegen könnte:
    Nein, der EVH ist deprecated, aber bringt nichts zum abstürzen. Das ist ein Indikator für eine sehr veraltete Mod.


    AmaZiinG schrieb:

    Wenn ich infinstar ausmache dann funktioniert nix mehr. Man kann das ACE 3 Menü nicht mehr aufmachen und man kann auch nix mehr mit TFR machen.
    Das ist eine Sache, an der ich ansetzen würde. Entferne die Mods, die du mitlädst, einzeln und versuche den Fehler zu reproduzieren.

    Ein aktuelles Log ohne Infistar Spam usw. würde auch eher helfen. Zudem: seit wann tritt der Fehler auf?
    "Sie haben Feinde? Super! Das heißt, dass Sie sich in Ihrem Leben für etwas eingesetzt haben." - Winston Churchill
  • chris579 schrieb:


    Das ist eine Sache, an der ich ansetzen würde. Entferne die Mods, die du mitlädst, einzeln und versuche den Fehler zu reproduzieren.

    Ein aktuelles Log ohne Infistar Spam usw. würde auch eher helfen. Zudem: seit wann tritt der Fehler auf?
    Ich habe es schon alles durchgetestet. Ich kann morgen mal ein log schicken ohne Infinstar. Der Fehler tretet wie gesagt nach 10 Spielern auf.
  • Du machst es echt nicht leicht :D

    Ja, die Mission einfach mal hochladen irgendwo, damit kundige Leute wie commy2 einen Blick darauf werfen können.
    Was chris579 meinte war eher: Hats vorher schon mal funktioniert oder gehts erst seit kurzem (Zeitraum) nicht mehr? Wenn erst sei kurzem: Was hast du eingebaut, hast du schon probiert eben jenes zu löschen bzw. rückgängig zu machen?

    Wenns noch nie funktioniert hat, hast du schon versucht das ganze ohne eigene Basteleien zu machen?
    Also, Arma nur mit den Mods und einer fertigen Mission. Wenn du unbedingt Altis spielen willst, wird ja wohl irgendwo ein Altis herumkugeln wo "@extDB3;@life_server;@CBA_A3;@ace;@Syndicate_Life;@ACEX;@task_force_radio" eben jene Mods dabei sind, ohne, dass selbst herumgebastelt werden muss.
    Mitglied bei der virtuellen Panzergrenadierbrigade 37 (vpzgrenbrig37.de/)
    Mein Youtube-Kanal: youtube.com/channel/UCopJOTFI3YmFBdAynaiZqGg
  • Natrius schrieb:

    Was chris579 meinte war eher: Hats vorher schon mal funktioniert oder gehts erst seit kurzem (Zeitraum) nicht mehr? Wenn erst sei kurzem: Was hast du eingebaut, hast du schon probiert eben jenes zu löschen bzw. rückgängig zu machen?
    Ja es hat mal alles funktioniert vor ungefähr einen Jahr hatte ich schon einen Server. Diesen habe ich dann aber nochmal ausgeschaltet weil mir einige Sachen an der JC Karte nicht gefielen. Die Skripte etc. haben sich kaum geändert.

    Natrius schrieb:

    Wenns noch nie funktioniert hat, hast du schon versucht das ganze ohne eigene Basteleien zu machen?
    Also, Arma nur mit den Mods und einer fertigen Mission. Wenn du unbedingt Altis spielen willst, wird ja wohl irgendwo ein Altis herumkugeln wo "@extDB3;@life_server;@CBA_A3;@ace;@Syndicate_Life;@ACEX;@task_force_radio" eben jene Mods dabei sind, ohne, dass selbst herumgebastelt werden muss.
    Ich habe es noch nicht versucht aber ich glaube es wird halt kaum an den Skripten etc. liegen in der Mpmisson.

    Ich habe mal meine Misson jetzt hochgeladen

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von AmaZiinG ()

  • Ich kann jetzt auf die schnelle nichts in der Mission erkennen, dass den Fehler begründen könnte. Denke mal es wird daher von @Syndicate_Life ausgehen. Ohne dieses Modpaket wird die Mission wahrscheinlich nicht laufen. Man kann den Fehler trotzdem nur über Ausprobieren finden: Alles rausnehmen, sodass ACE und TFAR wieder funktionieren und dann nach und nach die anderen Mods hinzufügen bis der alte Fehler auftaucht. Wenn dann der Auslöser des Problems gefunden ist, kann man den sich vielleicht noch mal genauer anschauen.
  • Ohne den Fehler bringen die logs auch nicht viel.



    19:46:54 Error in expression <e_common_oldVisibility", _vis];
    _object setUnitTrait ["camouflageCoef", _vis];
    }>
    19:46:54 Error position: <setUnitTrait ["camouflageCoef", _vis];
    }>
    19:46:54 Error Type Any, expected Number,Bool
    19:46:54 File z\ace\addons\common\XEH_postInit.sqf, line 59

    Ich glaube das habe ich schonmal gesehen. Ich glaube das ist schon in der nächsten ACE version gefixed.


    FUEL STATIONS READY CEROSIN = 21$/Liter"
    Was bitte ist "Cerosin"? Soll das Kerosin heißen?