Objekt Import Problem - Keine Anzeige im Editor

  • Sonstiges

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Objekt Import Problem - Keine Anzeige im Editor

    Hallo Leute,

    ich bin neu hier im Forum. Ich habe nun schon einige Zeit Probleme mit dem Import von statischen Modellen in Arma 3.
    Egal was ich mache, das Objekt wird nie im Editor angezeigt.

    Ich möchte, dass mein Testobjekt, ein Würfel, im Editor auswählbar und platzierbar ist. Ich habe jetzt schon einige Sachen ausprobiert und auch die Suchfunktionen
    im Forum genutzt, aber ich konnte das Problem nicht lösen. Der Addon Builder macht jedoch keine Probleme, es wird also so gut wie nie ein Fehler angezeigt.

    Da ich jedoch keine Erfahrung im Skripten habe, fällt mir diese
    wahrscheinlich einfache Aufgabe schwer.

    Ich bin folgendermaßen vorgegangen:

    Ich habe ein Objekt in Blender erstellt und es als .p3d exportiert.
    Daraufhin importierte ich es in den Objekt Builder und speicherte
    es in einem Odner ab als .p3d ab. Als nächstes erstellte
    ich die config.cpp, die folgenden Code enthält:


    Quellcode

    1. class cfgPatches
    2. {
    3. class Test2
    4. {
    5. units[] = {"Test2"};
    6. weapons[] = {};
    7. requiredVersion = 1;
    8. requiredAddons[] = {"A3_Data_F"};
    9. };
    10. };
    11. class CfgVehicle
    12. {
    13. displayName = "Test2";
    14. model = "Test2\Test2.p3d";
    15. editorCategory = "EdCat_Default";
    16. editorSubcategory = "EdSubcat_Default";
    17. scope = 2
    18. };
    19. };
    Alles anzeigen
    Nachdem ich daraufhin dann mit Hilfe des Addon Builders die .pbo erhielt,
    verschiebt ich diese in den Addon Ordner von Arma und startete das Spiel.
    Doch im Editor war leider kein Objekt zu finden. Ich bin mir ziemlich sicher das dieser Code Müll ist, aber weiter bin ich einfach nicht gekommen.

    Ich hoffe ihr könnt mir in dieser Situation helfen


  • Hallo String

    Da fehlen ein paar sachen aber hier mal ne neue version

    XML-Quellcode

    1. class CfgPatches
    2. {
    3. class tag
    4. {
    5. units[]={"tag_test"};
    6. weapons[]={};
    7. requiredVersion= 1.00;
    8. version= 1.00;
    9. fileName = "test.pbo";
    10. author = "Test";
    11. };
    12. };
    13. class CfgVehicles
    14. {
    15. class Strategic;
    16. class tag_test : Strategic
    17. {
    18. scope = 2;
    19. model = \Test2\Test2.p3d;
    20. displayName = "Tag Test";
    21. editorCategory = "EdCat_Default";
    22. editorSubcategory = "EdSubcat_Default";
    23. };
    24. };
    Alles anzeigen