Arma3Sync " Problem beim Repo erstellen"

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Arma3Sync " Problem beim Repo erstellen"

    Hallo Repo-Freunde.
    Vielleicht kann mir jemand von euch bei meinem Problem helfen.
    Ich lade eine Repo auf unseren Server (Linux), dort finde ich diese dann auch.
    Beim Vergleichen zwischen Server und meinem Modordner sehe ich dann aber Unterschiede (gelbes Dreieck).
    Und zwar sind es diese zsync Dateien die zuerst nur in meinem Modordner sind. Wenn ich auf "download" gehe ist alles ok.
    Das ist das Eine, das andere ist das erneute "build".
    Wenn ich etwas an der Repo ändere und dann erneut "build" mache, wird wieder die gesamte Repo hochgeladen.
    Auch wenn ich nichts ändere und erneut upload klicke passiert das selbe.
    Ich denke es sollten dann nur Dateien hochgeladen werden die neu dazu gekommen sind. Und wenn sich nicht geändert hat,
    sollte auch nichts hochgeladen werden.
    Hat jemand eine Ahnung woran das liegen könnte ?
    Warum reiben sich Frauen morgens nach dem Aufstehen die Augen?
    Weil sie keine Eier zum Kratzen haben!


    tactical faction action & insurrection
    steamcommunity.com/sharedfiles/filedetails/?id=697756742
  • Hallo Muecke,

    bei der Upload-Funktion von ArmA3Sync ist es leider so. Wenn es keine großen Mods sind, mache ich einen manuellen Upload mit WinSCP. Wenn es zu unübersichtlich wird, nutze ich unter WinSCP die Funktion "Synchronisieren".

    [ATTACH=CONFIG]429[/ATTACH]

    Das Problem mit den zsync-Dateien habe ich nicht ganz verstanden.
    Bilder
    • winscpsync.jpg

      39,2 kB, 498×468, 334 mal angesehen
  • Hallo chibureck,
    du meinst also dass es normal ist dass immer das gesamte Repo hochgeladen wird ?

    Die zsync Dateien sind nach dem build in meinem Repo Modordner überall.
    Nach einem download vom Server in diesen sind alle wieder verschwunden.
    Das mit dem WinSCP muss ich mir bei Gelegenheit mal ansehen...
    Warum reiben sich Frauen morgens nach dem Aufstehen die Augen?
    Weil sie keine Eier zum Kratzen haben!


    tactical faction action & insurrection
    steamcommunity.com/sharedfiles/filedetails/?id=697756742
  • Die Zsync-Dateien werden bei Synchronisation über HTTP benötigt. Sie werden beim Upload über ArmA3Sync nicht mit hochgeladen (war zumindest früher so).

    Wie es aussieht, machst du deinen Build mit den Mods direkt im ArmA3-Ordner. Dann ist es schon richtig, dass er die Zsync-Dateien löscht, weil sie ja nicht zur Repo gehören. Ich persönlich habe mir für die Repo einen Ordner unter "Eigene Dokumente" angelegt und nutze die Synchronisation über HTTP. Deswegen auch der Upload über WinSCP . Anschließend teste ich den Download per ArmA3Sync selbst, bevor ich das Update offiziell freigebe.

    Grüße
    chiburek
  • Danke für deine Hilfe Chiburek.
    Ich habe das so wie du es beschrieben hast nochmal versucht. Auch mit Extraordner und Synchro über Http.
    Wie gesagt, Benutzer können herunterladen und sich synchronisieren. Jedoch bleibt das Problem mit dem gesamten erneuten hochladen bei kleinen Änderungen.
    Das macht so keinen Sinn.
    Das WinSCP hab ich mir mal eben installiert. Scheint ganz cool zu sein.
    Ich vermute es werden aber keine .7z Dateien im Bezug auf Inhalt synchronisiert, um Zeit zu sparen.
    Die ganze Datei oder nix, denk ich. Aber Danke trotzdem, eventuell fällt mir da was ein.


    @X39
    Danke, das wäre sicher perfekt. Leider hab ich nur Zugriff über FTP...
    Warum reiben sich Frauen morgens nach dem Aufstehen die Augen?
    Weil sie keine Eier zum Kratzen haben!


    tactical faction action & insurrection
    steamcommunity.com/sharedfiles/filedetails/?id=697756742
  • Muecke schrieb:

    Danke für deine Hilfe Chiburek.
    Ich habe das so wie du es beschrieben hast nochmal versucht. Auch mit Extraordner und Synchro über Http.
    Wie gesagt, Benutzer können herunterladen und sich synchronisieren. Jedoch bleibt das Problem mit dem gesamten erneuten hochladen bei kleinen Änderungen.
    Das macht so keinen Sinn.
    Das WinSCP hab ich mir mal eben installiert. Scheint ganz cool zu sein.
    Ich vermute es werden aber keine .7z Dateien im Bezug auf Inhalt synchronisiert, um Zeit zu sparen.
    Die ganze Datei oder nix, denk ich. Aber Danke trotzdem, eventuell fällt mir da was ein.


    @X39
    Danke, das wäre sicher perfekt. Leider hab ich nur Zugriff über FTP...


    kennst du den Admin (also ist es kein pure-server host wie z.b. nitrado)?
    wenn ja sag ihm er soll dir einen zugriff anlegen nur mit userrechten
    wenn man es vernünftig macht hast du auch nur zugriff per ssh auf besagten ordner und bist in der lage vernünftig mit A3S zu arbeiten
  • chiburek schrieb:

    Mit der Console.sh hat mich bei einem Build das wiederholte Angeben der Daten wie z. B. die "hidden folders" gestört. Kann man das irgendwie Umgehen?


    man kann alles was man über die console.sh macht auch direkt in ein skript packen (glaube ich zumindest mal irgendwo gelesen zu haben als ich die console.sh gesucht hatte)
    hab mich jedoch nicht wirklich damit beschäftigt da ein einfaches aufrufen genügt hatte und ich mich nicht einlesen wollte :10_whistling:


    am ende wäre jedoch meiner meinung nach die entwicklung eines eigenen tools durchaus sinnvoller ...
    A3S ist halt nur ganz nett ... (aber sucht mal jemanden der sich bereitwillig an ein solches tool macht :P)
  • So, es geht jetzt !
    Es lag an ArmA3Sync selbst. Letzte Nacht gab es ein Update.



    • Fixed: Repository upload: full re-upload is performed if FTP upload protocol is different from repository protocol.
    • Fixed: Importing autoconfig failed if server is case sensitive for url.


    Beide Fehler waren bei mir das Problem.
    Zusammengefasst also, es lädt jetzt nicht jedes mal die komplette Repo hoch, sondern nur das was neu ist.
    Auch die Autoconfig (URL) wird richtig erstellt, was mich vorher schon gewundert hatte, wo ich aber den Fehler bei mir vermutet hatte.

    Dennoch vielen Dank an chiburek und x39 für eure Hilfe.
    Warum reiben sich Frauen morgens nach dem Aufstehen die Augen?
    Weil sie keine Eier zum Kratzen haben!


    tactical faction action & insurrection
    steamcommunity.com/sharedfiles/filedetails/?id=697756742
  • hallo

    hab mal eine frage bei mir liegt eher ein größeres Problem vor und zwar habe ich versucht mit vielen infos eine repo für arma3sync zu erstellen mit unterscheidlichen Programmen oder durchführungen ,ich habe eine Webserver (Nitrado) hatte es auch mit Dropbox getestet weil es angeblich auch ginge ...leider ohne erfolge oft den fehler das datei pfad mit/.a3s/sync nicht gefunden wurde oder andere ...hätte für mich irgendwer eine seite wo ich dafür ein TUT habe oder kann mir irgendwer schrieben was ich dafür brauche,etc ?

    wäre echt nett denn irgendwie komm ich nie weiter ...wenn es überhaupt richtig ist wie ich es mache

    danke
  • Ich verstehe nur Bahnhof was die Installation von Arma3Sync auf die Serverseite angeht.

    Java auf dem server geklatsch und schon lauter errors wenn ich die Arma3Sync.sh ausführen will.

    Spoiler anzeigen

    Exception in thread "main" java.lang.NoClassDefFoundError: com/jtattoo/plaf/aluminium/AluminiumLookAndFeel
    at java.lang.[lexicon]Class[/lexicon].getDeclaredMethods0(Native Method)
    at java.lang.[lexicon]Class[/lexicon].privateGetDeclaredMethods([lexicon]Class[/lexicon].java:2625)
    at java.lang.[lexicon]Class[/lexicon].getMethod0([lexicon]Class[/lexicon].java:2866)
    at java.lang.[lexicon]Class[/lexicon].getMethod([lexicon]Class[/lexicon].java:1676)
    at sun.launcher.LauncherHelper.getMainMethod(LauncherHelper.java:494)
    at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:486)
    Caused by: java.lang.ClassNotFoundException: com.jtattoo.plaf.aluminium.AluminiumLookAndFeel
    at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
    ... 6 more


    [bin auch kein freund von Java! aber das steht nicht zur Diskision)

    Also kein plan wie ich diese Autoconfig erstellen soll oder die schon bestehenden [lexicon]addons[/lexicon] die sich auf dem Server befinden für das auswählen soll.

    Spoiler anzeigen
    Ich bin auch am zweifeln ob dieses Arma3sync unbendigt für eine Gruppe sein muss. da sich die Meisten maneull die [lexicon]Addons[/lexicon] von Armaholic und/oder six beziehen...und vorallem was arma3sync für veränderungen mit sich bringt habe nähnloch auch keine lust für eine neues [lexicon]addon[/lexicon] denn ganzen mist 8 mal Pro stunde zu machen.



    Solltet ihr aber dennoch ideen haben was das ist und wie ich es behebend kann wäre es cool.


    UPDATE!

    Nun ja ich bin weiter gekommen und wie ich bemerkt habe is die nacht um xD Nun was mich verwirrt ist das mit denn pfardeinstellungen die sind nicht grade klar...mal sehen ...jetzt wo ich ein schrit näher gekommen bin kann ich denn Mist ja Löschen und neu machen sollte das nicht klappen^^
    Ich komme aus der Milsim Gruppe -> 85th Operations Command
    85th-operations-command.de/
    Viele Grüße

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von John Sheppard ()